Scheduled for 17.09.2025 at 14:00 – 18:00
Affects
Finland (FIP)
Under maintenance from 2:00 PM to 6:00 PM
Completed
17.09.2025 at 18:00Completed
17.09.2025 at 18:00Maintenance has completed successfully
In progress
17.09.2025 at 14:00In progress
17.09.2025 at 14:00Maintenance is now in progress
Planned
17.09.2025 at 14:00Planned
17.09.2025 at 14:00We have scheduled maintenance for this time with disruptions to the services.